Jump to content


Photo

G27 H shifter gear jumping problem


  • Please log in to reply
8 replies to this topic

#1 KZ2Iceman97

KZ2Iceman97

    Novice

  • Member
  • 47 posts
  • Facebook:Cameron Scott Dance
  • Twitter:KZ2Iceman97
  • LocationAuckland, New Zealand

Posted 08 April 2015 - 05:53 AM

Ok so recently for some odd reason. When I'm using my H shifter with my G27 it seems to jump gears when engaged in another. E.g atm I'll pluck 6th gear and maybe 2 seconds after being in 6th gear it randomly jumps into 4th gear for a few seconds and then back to 6th while being in the 6th gear gate the whole time which is a major loss and pain in the ass because the engine is either in flames or I'm way out of the power band for 6th. My G27 is just under a year old and this problem has only just started happening in the past few days. Any help would be appreciated. Thanks in advance


KZ2Iceman97 Both sim & real world racer | The flying Kiwi 
iceshard989 on YouTube | KZ2Iceman97 on Twitter | Cameron Scott Dance on Facebook

#2 ingange

ingange

    Crew Chief

  • Member
  • 504 posts
  • LocationMaribor

Posted 08 April 2015 - 01:10 PM

1st thing that came in my head when i read your post was autoshift on . If it is not that could be something mehanical wrong in shifter . If it is randrom it cant be software i think .
Racing is what real men do while the boys play football .

http://addictedtospeed.enjin.com/ <--- Home Of Addicted To Speed

#3 KZ2Iceman97

KZ2Iceman97

    Novice

  • Member
  • 47 posts
  • Facebook:Cameron Scott Dance
  • Twitter:KZ2Iceman97
  • LocationAuckland, New Zealand

Posted 08 April 2015 - 11:01 PM

1st thing that came in my head when i read your post was autoshift on . If it is not that could be something mehanical wrong in shifter . If it is randrom it cant be software i think .

Never have autoshift on and it will happen on pretty much everything else as well as SRW. (e.g. GSCE, rFactor, AC, etc)


KZ2Iceman97 Both sim & real world racer | The flying Kiwi 
iceshard989 on YouTube | KZ2Iceman97 on Twitter | Cameron Scott Dance on Facebook

#4 tomcat458

tomcat458

    Lurker

  • Member
  • 0 posts

Posted 11 April 2015 - 11:02 AM

I have the same problem, but in 2nd gear, it kind of became connected with 4th..but dont know what to do..Coss said to look inside, but I dont want to mess with it..



#5 KZ2Iceman97

KZ2Iceman97

    Novice

  • Member
  • 47 posts
  • Facebook:Cameron Scott Dance
  • Twitter:KZ2Iceman97
  • LocationAuckland, New Zealand

Posted 12 April 2015 - 01:12 AM

I have the same problem, but in 2nd gear, it kind of became connected with 4th..but dont know what to do..Coss said to look inside, but I dont want to mess with it..

Mine has started to do it with both 4th & 2nd now but instead of going into gear when I put the stick into the gate it will just go to neutral. I too want to look but would rather not play around with the insides and screw it up even more


KZ2Iceman97 Both sim & real world racer | The flying Kiwi 
iceshard989 on YouTube | KZ2Iceman97 on Twitter | Cameron Scott Dance on Facebook

#6 Mesder13

Mesder13

    Seasoned

  • Member
  • 66 posts

Posted 12 April 2015 - 04:36 AM

You can undo the six screws around the outside of the shifter, then remove the plastic top with the shift pattern on it (Just a couple of plastic clips, you can just pop that straight off if you didn't know already) and undo the screw in there, the thing will open up fairly easily. You can at least get a look inside to see if anything is visibly broken, even if you don't mess with anything.



#7 KZ2Iceman97

KZ2Iceman97

    Novice

  • Member
  • 47 posts
  • Facebook:Cameron Scott Dance
  • Twitter:KZ2Iceman97
  • LocationAuckland, New Zealand

Posted 12 April 2015 - 09:18 AM

You can undo the six screws around the outside of the shifter, then remove the plastic top with the shift pattern on it (Just a couple of plastic clips, you can just pop that straight off if you didn't know already) and undo the screw in there, the thing will open up fairly easily. You can at least get a look inside to see if anything is visibly broken, even if you don't mess with anything.

I had a bit of a look earlier today and nothing appears to be broken or damaged from what I saw. Might just have another look to make sure I didn't miss anything


KZ2Iceman97 Both sim & real world racer | The flying Kiwi 
iceshard989 on YouTube | KZ2Iceman97 on Twitter | Cameron Scott Dance on Facebook

#8 Mesder13

Mesder13

    Seasoned

  • Member
  • 66 posts

Posted 12 April 2015 - 02:42 PM

I had a bit of a look earlier today and nothing appears to be broken or damaged from what I saw. Might just have another look to make sure I didn't miss anything

hmm, idk what it could be then, if none of the hardware inside is broken... Maybe something is loose inside and sometimes it accidentally triggers the gear next to it? I don't know exactly how the shifter recognizes what gear it's in, but that would be my best guess.



#9 KZ2Iceman97

KZ2Iceman97

    Novice

  • Member
  • 47 posts
  • Facebook:Cameron Scott Dance
  • Twitter:KZ2Iceman97
  • LocationAuckland, New Zealand

Posted 12 April 2015 - 10:31 PM

hmm, idk what it could be then, if none of the hardware inside is broken... Maybe something is loose inside and sometimes it accidentally triggers the gear next to it? I don't know exactly how the shifter recognizes what gear it's in, but that would be my best guess.

That is a possibility. It could be the only real reason behind it besides hardware that may be damaged or broken that isn't visible unless it's taken apart a bit more


KZ2Iceman97 Both sim & real world racer | The flying Kiwi 
iceshard989 on YouTube | KZ2Iceman97 on Twitter | Cameron Scott Dance on Facebook




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users